Image Hosted by ImageShack.us

Se ci guardiamo un po’ attorno, gli unici due tool simili a WebKam sono Camorama e Cheese. Mentre il primo ormai non riesce piu’ a stare al passo con le piu’ recenti webcam e i driver in continua evoluzione, il secondo non rientra nella pletora di programmi integrati (e’ in gtk).
Da qui nasce la necessita’ di colmare quel vuoto che da sempre persiste in ambiente desktop KDE.

WebKam e’ praticamente lo stesso modulo che troviamo in Kopete (l’applicazione kde per l’IM) “estrapolato” e “trasformato” in un applicazione stand-alone, con in piu’ l’aggiunta di un bottone per scattare lo screenshoot. Alcune modifiche sono state apportate anche all’ergonomia e alla funzionalita’ degli slide-level per una resa grafica, a detta del programmatore, leggermente migliore.
In questa fase di sviluppo tuttavia non e’ stata implementata alcuna compatibilita’ con la maggior parte delle webcam presenti sul mercato.

Installazione

Nel pacchetto disponibile per il download ci sono sia i sorgenti che il pacchetto debian per Ubuntu. Dal momento che non e’ specificata alcuna versione, ho preferito (come sempre) spendere quelle 2 calorie in piu’ per compilare webkam con cmake.

  • Download webkam.tar.gz
  • NB: E’ necessario avere installato kde4, sia la versione dei repository che quella proveniente da SVN.

    tar xvfz 76902-webkam.tar.gz
    cd ~/webkam-devel
    cmake .
    make
    sudo make install

    Lanciamo:

    webkam

    Sprovvisto di una cam decente al momento della stesura di questo articolo, riporto lo screenshoot dell’autore:
    🙂

    Image Hosted by ImageShack.us

    Naturalmente, pur essendo dichiaratamente un clone di Cheese, mancano alcune features..in compenso Cheese con kde non funziona proprio benissimo .. spesso da’ problemi con la scheda video (altera colori e risoluzione del monitor).

    L’annuncio del progetto:

  • WebKam @ kde-apps
  • Related Posts Plugin for WordPress, Blogger...

    Il tuo indirizzo ip:
    3.229.122.219

    Valutazione 3.00 su 5
    happy wheels 2 demo

    Category:

    Senza categoria

    Tags:

    , ,

    Commenti via Facebook:

    Leave a Reply

    Your email address will not be published. Required fields are marked *

    *

    10 Comments

    • ugaciaka ITALY Konqueror Ubuntu Linux 11 anni ago

      Eh, peccato che bisogna aver kde4 per farla girare 😉

        Quota

    • ciao, ho provato ad installarla con cmake però mi dice:
      “CMake Error: The installed Qt version 4.3.2 is too old, at least version 4.4.0 is required”
      io ho kde4 installato e lo sto aggiornando proprio ora (come tutti i giorni) via svn, con kdesvn-build. come bisogna fare per fargli capire dove sono le qt4.4 di kde? (io stesso non so bene dove siano)
      grazie mille!

        Quota

    • Divilinux ITALY Mozilla Firefox Linux 11 anni ago

      @charliedontsurf
      Le qt4.4 nei repository non ci sono..quelle che hai installato per kde4 sono in un altro percorso,e dipende dal file di configurazione .kdesvn-buildrc (io ho usato quello standard scaricabile da kde.org).
      E’ strano che la compilazione non passi per le qt4, dal momento che dovrebbe essere specificato nel file kdesvn-start ( di seguito il mio)

      export QTDIR=/opt/qt4
      export KDEDIR=/opt/kde4
      export KDEHOME=$HOME/.kde4
      export LD_LIBRARY_PATH=$KDEDIR/lib:$LD_LIBRARY_PATH
      export PATH=$QTDIR/bin:$KDEDIR/bin:/usr/local/bin:$PATH

      Inizia a controllare la versione di qmake in uso con:

      sudo update-alternatives –config qmake

      ..devi selezionare qmake-qt4..poi riprova la compilazione

        Quota

    • ciao e grazie mille…il mio .kdesvn-buildrc dice così (nella parte iniziale)

      use-stable-kde false
      source-dir /usr/src/kde4
      # build-dir build
      kdedir /opt/kde4
      # make-install-prefix sudo -S
      qtdir /opt/qt4 # Default to installing Qt (Qt 4).
      # qtdir ${build-dir}/build/qt-copy # Use built Qt (Qt 3).
      cmake-options -DCMAKE_BUILD_TYPE=release
      cxxflags -pipe -march=i686

      il mio kdesvn-start è identico al tuo e dando
      sudo update-alternatives –config qmake
      è già selezionata (penso) la seconda opzione come puoi vedere:

      Ci sono 2 alternative che forniscono `qmake'.

      Selezione Alternativa
      -----------------------------------------------
      + 1 /usr/bin/qmake-qt3
      * 2 /usr/bin/qmake-qt4

      grazie mille!

        Quota

    • Divilinux ITALY Mozilla Firefox Linux 11 anni ago

      vediamo..se ho capito bene la situazione, hai probabilmente le qt 4.3 installate dai repository..e di default cmake prende quelle
      Cercale con synaptic e rimuovile..il pacchetto dovrebbe essere:

      libqt4-dev

      poi, se non vado errato, probabilmente e’ sbagliato questo percorso

      export QTDIR=/opt/qt4

      Dovrebbe essere

      export QTDIR=/opt/qt4/bin

      Vado per logica dal momento che utilizzo le librerie qt4.4 installate da me in:

      /usr/local/Trolltech/Qt-4.4.0-beta1/bin

        Quota

    • ho disinstallato come hai detto tu libqt4-dev, ora mi dice che ci son solo le qt3 per qmake. quindi adesso devo solo più scaricarmi le qt4.4 e installarmele manualmente? io pensavo bastassero quelle utilizzate con kdesvn-build…

        Quota

    • Divilinux ITALY Mozilla Firefox Ubuntu Linux 11 anni ago

      @charliedontsurf
      e’ un po’ inutile, ma se scarichi e compili con configure, make e make install le librerie qt4.4 del sito trolltech..secondo me fai prima che capire dove sia il problema di percorso..

        Quota

    • ora magari provo a scaricarle dal sito trolltech…anche perchè il metodo di modificare .bashrc funziona quando si tratta di installare e compilare cose a livello utente, ma se già devo andare a compilare in cartelle tipo /usr/src/kde4 e devo usare il super utente non me le trova più…

        Quota

    • fulvio1 ITALY Mozilla Firefox Ubuntu Linux 11 anni ago

      volevo segnalare che hanno creato un comodo pacchetto .deb per Ubuntu

      http://www.kde-apps.org/content/show.php/webKam?content=76902

      che si può scaricare direttamente al sito

      http://www.kde-apps.org/content/download.php?content=76902&id=2&tan=43406933

      A me funziona addirittura con una webcam Microdia (che programmi come camorama neanche rilevano)!!!
      Grazie e complimenti!!

        Quota

    • Non è stata implementata compatibilità con i vari modelli?
      Usa video4linux. I driver stanno nel kernel non nelle applicazioni.

        Quota