Free Image Hosting at www.ImageShack.us

Ormai sono stati scritti centinaia di howto su questo splendido Desktop Manager..percio’ mi limitero’ ad una timida e fredda spiegazione di quei pochi passaggi che bisogna compiere per ottenere e17 sulla nostra Kubuntu-box (o quellochevolete-box)

METODO VECCHIA ROMAGNA (etichetta nera)

..il gusto che crea l’atmosfera.
Per una scorpacciata di Enlightenment da soli o in compagnia,il metodo migliore e’ aggiungere i repository al nostro /etc/apt/sources.list

sudo kate /etc/apt/sources.list

Qualche buon anima ci ha superdotato di..:

sudo software-properties-kde

…questo tool eccezzionale che permette di risparmiare ben 2 calorie per aprire un editor di testo (kate,pico,nano,vi,di,a,da,in,con,su,per,tra,fra..)

Aggiungiamo questi repository:

## e17 edevelop.org
deb http://edevelop.org/pkg-e/ubuntu feisty e17
deb-src http://edevelop.org/pkg-e/ubuntu feisty e17

Chiave pubblica (col tool di prima.. o da console)

wget http://lut1n.ifrance.com/repo_key.asc
sudo apt-key add repo_key.asc

Ora un bel:

sudo apt-get update
sudo apt-get install e17 engage

Riavviamo KDE e selezioniamo la sessione e17 dal KDM

METODO CHIANTI IN CHIUSURA

ATTENZIONE: disinstallare e17 dal gestore pacchetti se si vuole utilizzare questo metodo.

* Installiamo tutti i pacchetti necessari:

sudo apt-get install build-essential cvs libtool libltdl3-dev automake1.9 autotools-dev libpopt-dev libcurl3-dev libx11-dev x11proto-xext-dev libbz2-dev libid3tag0-dev libpng12-dev libtiff4-dev libungif4-dev libjpeg62-dev libssl-dev libfreetype6-dev bison flex xlibs-dev gettext libimlib2-dev libxml2-dev libxcursor-dev libgtk1.2-dev autoconf pkg-config libpng12-dev libxine-dev libxkbfile-dev libsqlite3-dev giblib-dev libxmu-dev libxdamage-dev libxcomposite-dev libtag1-dev libtagc0-dev giblib-dev libasound2-dev

* Preleviamo lo script di installazione dai repository CVS:

sudo apt-get install cvs
wget http://omicron.homeip.net/projects/easy_e17/easy_e17.sh

* Rendiamolo eseguibile..ed eseguiamolo!

chmod +x easy_e17.sh
./easy_e17.sh -i

Lo script chiedera’ la password da inserire. Bisogna pazientare un po’ perche’ easy_e17 installera’ tutte le applicazioni e le librerie necessarie in /opt/e17 per non interferire con altre versioni di enlightenment(non si sa mai). E’ possibile tuttavia specificare un percorso diverso durante l’installer.
Se ci fossero problemi:
sudo kate /etc/environment
Aggiungiamo:
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/opt/e17/bin

Per aggiungere la sessione al KDM

sudo kate /usr/share/xsessions/e17.desktop

All’interno scriviamo questa entry:

[Desktop Entry]
Encoding=UTF-8
Name=E-17
Comment=
Exec=/opt/e17/bin/enlightenment_start #grazie Imu
Icon=
Type=Application

Maggiori informazioni:

Enlightenment – Start-up e temi
Wiki CVS

Related Posts Plugin for WordPress, Blogger...

Il tuo indirizzo ip:
54.221.9.6

Valutazione 3.00 su 5
happy wheels 2 demo

Category:

Senza categoria

Tags:

Commenti via Facebook:

Leave a Reply

Your email address will not be published. Required fields are marked *

*

30 Comments

  • divi dimmi dove la prendi che dev’esser buona 😀 bellissimo E cmq !

      Quota

  • NevidS ITALY 11 anni ago

    Il sistema vecchia romagna sembra veramente interessante. Appena ripristino la connessione quasi quasi provo.

      Quota

  • @NevidS
    e’ facile come bere un bicchiere d’acqua.
    Una volta per installare e17..non era cosi’..lol

      Quota

  • Mela (jerrad) ITALY 11 anni ago

    Divi ho un piccolo problema… quando do il comando:

    sudo software-properties-kde

    non mi si apre e da terminale l’output è:

    /usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API not stable yet
    warnings.warn(“apt API not stable yet”, FutureWarning)
    Error: could not find a distribution template

    Non è che può essere legato al fatto che adept non mi apre la gestione repository?

      Quota

  • roberto ITALY 11 anni ago

    Non vorrei dire cavolate.. ma c’è un errore? (sudo kate /etc/sources.list non sudo kate /etc/apt/sources.list)
    Bellissimo blog complimenti!

      Quota

  • @roberto
    si grazie..e’ stata una svista,ora ho sistemato
    @Mela
    mi metti in difficolta con quel tool..lo tiro fuori solo quando devo fare gli screenshot altrimenti non lo uso mai
    pero’ sicuramente c’e’ un bell’errore..non saprei dire dovuto a cosa ..dovrei cercare in rete pure io

      Quota

  • errata corrige -> dopo la riga “sudo software-properties-kde”

    errata: sistema ecceZzionale
    corrige: sistema eccezionale

    Ma hai visto troppi film trash di Abatantuomo ?
    Sono un tipo eccezzunalo veramento!
    😛

    con lo zio e la zia non ci vuole 2zeta!
    😉

      Quota

  • @kijio
    adesso vengo sul tuo blog e alla prima consonante sbagliata te lo faccio notare
    tra l’altro e’ Abatantuono..non Abatantuomo
    😉

      Quota

  • wesbluemarine ITALY 11 anni ago

    divi te lo dicevo appunto l’altro giorno che ho provato a metterlo su ubuntu…. 😀
    fossi in te proverei anche entrance, il login di e17…è davvero spettacolare!

      Quota

  • @wes
    si stasera mi faccio un girello tra i temi
    😀

      Quota

  • @ divilinu
    LOL …

      Quota

  • provato! è davvero “leggero” e poi l’effetto fiamme è troppo bello 🙂
    E’ sempre un piacere leggerti perchè si imparano sempre cose nuove!

      Quota

  • wesbluemarine ITALY 11 anni ago

    sì e17 è leggero ma quando carichi programmi in gtk o qt comincia ad essere la stessa zolfa di gnome o kde…..ma le nuove librerie di e17 sono così potenti?

      Quota

  • @Divilinux
    Gia dalla versione “0.16.999.036” che usavo ai tempi della dapper l’avvio era stato modificato nel file e17.desktop, la riga da correggere è la seguente :
    Exec=/opt/e17/bin/enlightenment_start
    Se dai uno sguardo sul mio vecchio sito su altervista trovi un articolo sullo script “easy_e17.sh” dove seguivo l’evoluzione di E17, oppure se lo hai installato da repository basta guardare il file ” /usr/share/xsessions/enlightenment.desktop ” che ti ha creato.

      Quota

  • @imu
    grazie per la precisazione
    i repo cvs ancora non li ho provati..coi i .deb la sessione parte normalmente senza aggiunte
    stasera aggiorno l’articolo
    😉

      Quota

  • @divilinu
    Di nulla amico 🙂 solo che mi sono permesso altrimenti qualcuno avrebbe iniziato a bombardarti di domande sul perchè a compilazione riuscita con lo script non si riuscisse ad avviare E17 ( mi è gia capitato ) 😉

      Quota

  • robiw72 ITALY 11 anni ago

    sto usando e17 da qualche ora…. esteticamente e’ carino, ma lo trovo poco intuitivo…. forse e’ solo questione di entrare nell’ottica!!!!
    ma il problema maggiore che ho riscontrato e’ che non ho i diritti di root su adept manager…. come’ possibile? come faccio a rimediare?

      Quota

  • @robinw72
    perche’ se lanci sudo adept_manager o kdesu adept_manager vuoi dire che non funziona?

      Quota

  • robiw72 ITALY 11 anni ago

    lanciando il comando da terminale funziona benissimo….. non va quando voglio aprirlo dal menu’ (applicazioni – strumenti di sistema – adept manager) la stessa operazione con kde funziona

      Quota

  • applicazioni – strumenti di sistema

    Lol..era cosi’ un anno e mezzo fa quando ho installato Kubuntu
    😀
    a parte gli scherzi..provero’ anche io a fare quanto dici per potertelo confermare o meno
    ma se lanci il kmenuedit dovresti trovare il comando “adept_manager” come sempre..quindi non credo che si sia reimpostato da solo.
    Se proprio non si avvia..aggiungi (sempre col kmenuedit) kdesu davanti ad adept_manager
    cosi’ deve funzionare per forza…

      Quota

  • RAndomX ITALY 11 anni ago

    Ho impostato un tema ma non mi fa visualizzare più nessuna scheda… come faccio a ripristinare quello predefinito???

      Quota

  • @ RAndomX
    Apri un terminale e scrivi :
    rm -rf ~/.e/e/config/*

      Quota

  • con il sistema “vecchia romagna” ho un problema con engage …
    consigli? suggerimenti?

    # sudo apt-get install engage
    “I seguenti pacchetti hanno dipendenze non soddisfatte:
    engage: Dipende: libecore1-dbus ma non è installabile
    Dipende: examine ma non sta per essere installato”

    mentre enlighment non da problemi .. almeno per l’installazione ..

      Quota

  • @Kijio
    e’ strano, ho controllato tra i pacchetti e io li ho. Credo che arrivino dallo stesso repositorio. Sono marcati come

    Debian Pkg-e Team

      Quota

  • ciao, guarda che il sistema a compilazione non funziona perchè si riferisce a pacchetti vecchi (Copia incolla dalla guida di imu per dapper / edgy). Insomma, da terminale esce questo su feisty:

    sudo apt-get install build-essential cvs libtool libltdl3-dev automake1.9 autotools-dev libpopt-dev libcurl3-dev libx11-dev x11proto-xext-dev libbz2-dev libid3tag0-dev libpng12-dev libtiff4-dev libungif4-dev libjpeg62-dev libssl-dev libfreetype6-dev bison flex xlibs-dev gettext libimlib2-dev libxml2-dev libxcursor-dev libgtk1.2-dev autoconf pkg-config libpng3-dev libxine-dev libxkbfile-dev libsqlite3-dev giblib-dev libxmu-dev libxdamage-dev libxcomposite-dev libtag1-dev libtagc0-dev giblib-dev libasound2-dev
    Password:
    Lettura della lista dei pacchetti in corso… Fatto
    Generazione dell’albero delle dipendenze in corso
    Lettura delle informazioni di stato in corso… Fatto
    build-essential è già alla versione più recente.
    autotools-dev è già alla versione più recente.
    autotools-dev set to manual installed.
    gettext è già alla versione più recente.
    autoconf è già alla versione più recente.
    autoconf set to manual installed.
    pkg-config è già alla versione più recente.
    Il pacchetto libpng3-dev è un pacchetto virtuale fornito da:
    libpng12-dev 1.2.15~beta5-1ubuntu1
    Bisogna esplicitamente sceglierne uno da installare.
    E: Il pacchetto libpng3-dev non ha candidati da installare
    darkmaster@darkmaster-desktop:~$ sudo apt-get install build-essential cvs libtool libltdl3-dev automake1.9 autotools-dev libpopt-dev libcurl3-dev libx11-dev x11proto-xext-dev libbz2-dev libid3tag0-dev libpng12-dev libtiff4-dev libungif4-dev libjpeg62-dev libssl-dev libfreetype6-dev bison flex xlibs-dev gettext libimlib2-dev libxml2-dev libxcursor-dev libgtk1.2-dev autoconf pkg-config libpng3-dev libxine-dev libxkbfile-dev libsqlite3-dev giblib-dev libxmu-dev libxdamage-dev libxcomposite-dev libtag1-dev libtagc0-dev giblib-dev libasound2-dev

    Quindi non funziona, prova a fare una guida aggiornata eprchè io, ad nesmepio, non so come cacchio fare con feisty! E le repos non funzionano, installano e16 invece del 17. Bella cavolata! (Non è colpa tua, sembra accada anche ad altra gente)

      Quota

  • @thedarkmaster
    apt-get ti dice che il pacchetto adesso si chiama

    libpng12-dev

    i pacchetti cambiano nomi spesso, e non posso certo passare ogni giorno in rassegna 300 articoli per controllarli uno ad uno. E’ grazie alle vostre segnalazioni che io posso aggiornare le guide..sempre con i dovuti modi, naturalmente..
    🙂

    molte delle dipendenze richieste le hai gia’, e il pacchetto da aggiornare nella guida mi pare che, per ora, sia solo libpng3-dev da sostituire con libpng12-dev.
    quello che non riesco a capire e’ come si sia installato e16..

      Quota

  • manco io, comunque la maggiorparte dei pacchetti dela lista non è che non ci sono, non si installano perchè pare abbiano dipendenze non soddisfatte! Strano… ad ogni modo vedi questi articoli per il problema di E16 vs E17

    http://ubuntuforums.org/showthread.php?t=461673
    http://ubuntuforums.org/showthread.php?t=460523

      Quota

  • @thedarkmaster
    tutti i programmi e le librerie indicate nell’articolo sono corrette e aggiornate per ubuntu feisty.
    Non e’ che magari ti manca qualche repository?
    E’ una questione di principio o perche’ hai bisogno di compilare i sorgenti..o ti interessa e17 indipendentemente dal metodo?..io l’ho installato dai repository.

      Quota

  • Mi interessa indipendentemente, non mi piace per nulla compilare, se posso evito sempre. Comunque come ho detto non riuscivo ad installare da pacchetti manco spennato. Comunque adesso ho la soluzione! Finalmente e me la sono sudata da solo. Sigh. Che poi alla fine almeno da soddisfazione, no? :_)
    comunque segui i link per la soluzione.

      Quota

  • @thedarkmaster
    che link devo seguire?..a me funziona

      Quota