Image Hosted by ImageShack.us

Con questa nuova versione del kernel, sono state introdotte delle patch molto importanti ,che potete consultare direttamente nel Changelog. Vediamo invece quali sono quelle piu’ interessanti dal punto di vista dell’uso desktop (periferiche sopratutto):

zd1211rw: Aggiunto supporto dispositivi AL2230S RF

ALSA usb-device :

Questa patch aggiunge esplicitamente un ID che coincide coi dispositivi Logitech QuickCam, i quali hanno una stringa specifica che identifica la classe del dispositivo.
La componente audio di questi dispositivi e’ ora disponibile (bug fix kernel 2.6.20)

Gentoo bugs
Launchpad
Alsa-project bugtrack

hda-intel : Risolto rilevamento audio-codec sui notebook Toshiba A100

Alcune schede hanno i codec audio sullo slot #3 mentre i codec del modem
sono sullo slot #0.Il driver dovrebbe continuare a provare gli slots quando nessun audio codec e’ stato trovato.
Questo risolve il problema del “no device” sui modelli Toshiba A100 (e anche altri controller ATI SB450)

– Dispositivi con tuner philips tda1316 tuner (V4L-DVB):

Linux-tv.org

– Problema ieee1394 & eth1394:

Questo fix aggiunge un device reale (tipo ethX) a eth1394..come nei kernel 2.6.20 e precedenti.
Avendo un device reale e non virtuale,gli script di Udev possono finalmente distinguere un interfaccia eth1934 da un bridge di rete ieee1934

Spero di aver tradotto bene piu’ che altro la sintassi, perche’ sono cose gia’ difficili da capire in italiano..Se ho scritto qualche castronata non esistate a farlo notare.
😉

Download kernel 2.6.21-5
Download changelog 2.6.21.5

Lo sto installando propio ora,perche’ il mitico

Linux kubuntu 2.6.20.1-ubuntu1-geko #1 SMP Thu Mar 15 22:33:15 CET 2007 i686 GNU/Linux

compilato e messo in funzione il 15 Marzo 2007 (esattamente a 2 giorni dall’acquisto!..via Vista,su Kubuntu..e kernel nuovo d’assalto), sta lentamente soffocando sotto il peso di un driver di cui ne farei volentieri a meno: Ndiswrapper.
Farei a meno anche dei GSPCA,che tornano prepotentemente a dare problemi con la versione 20070508

Breve parentesi sui GSPCA.

Il modulo contenuto nel kernel ufficiale di Ubuntu funziona normalmente, percio’ tutti coloro che ne seguono gli aggiornamento (per ora) possono stare tranquilli.
Il nuovo installer semi-semi-semi grafico (non e’ ncurses ma shell “colorata” come la chiamo io) e’ stato migliorato per far si che il modulo si compili e si installi lanciando:

sudo ./gspca_build

Image Hosted by ImageShack.us

Il problema, sia col 2.6.20 che col 2.6.21, e’ che

sudo modprobe gspca

restituisce:

FATAL: Error inserting gspca (/lib/modules/2.6.20.1-ubuntu1-geko/kernel/drivers/usb/media/gspca.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Se si prova a forzare il modulo,lanciando poi camorama il sistema si blocca e va riavviato spegnendo il computer col pulsante di accensione/spegnimento.

e l’errore e’ piuttosto evidente:

gspca: disagrees about version of symbol video_devdata

Se dovesse cambiare qualcosa (in senso positivo) dopo la compilazione di questo nuovo kernel (2.6.21-5) vi terro’ informati.

Related Posts Plugin for WordPress, Blogger...

Il tuo indirizzo ip:
54.198.55.167

Valutazione 3.00 su 5
happy wheels 2 demo

Category:

Senza categoria

Tags:

Commenti via Facebook:

Leave a Reply

Your email address will not be published. Required fields are marked *

*

3 Comments

  • macro182 ITALY 11 anni ago

    Ho una webcam della silvercrest e la tua procedura è andata a buon fine (2.6.20-16-386
    ); anche se, nel tentativo di farla riconoscere ad aMSN, non và già più!

    http://forum.ubuntu-it.org/index.php?topic=91214.msg598451#msg598451

    ;o)

      Quota

  • Caste ITALY 11 anni ago

    Sei a conoscenza del ‘famoso’ fischio da sotto la tastiera degli HP Pavilion della serie DV9000 e DV6000? Ecco, col ‘-generic’ non lo sento…se invece prendo il kernel e cambio anche solo una piccolissima spunta, un parametro qualsiasi, ecco che inizia a fischiettare come un ossesso.

    Ho passato una settimana a ricompilare kernel su kernel, sbattendoci la testa per due o tre ore a notte, ma proprio ieri mi ero detto: ‘Basta, mi sono rotto! Che vada al diavolo l’HP, mi tengo il -generic e saluti e baci!’

    …ora mi hai fatto di nuovo venire la fissa di capire perchè c’è questo càspio di fischio.
    Indi per cui: se la mia Lei mi lascia perché la tradisco col kernel, sarà soltanto colpa tua!

    😀

      Quota

  • @Caste
    il 2.6.21.5 funziona alla stragrandissima..
    ora lo voglio ricompilare con altre 2 patch che ho scovato in giro
    😉

      Quota