Image Hosted by ImageShack.us

Launchpad

Chi sara’ incappato in questo errore, si sara’ forse accorto della poca documentazione (spesso vecchie mailing list) e dei rimedi “verosimili”..coi quali si rischia di peggiorare una situazione che peggio di cosi’.. suona davvero difficile da credere; l’errore e’ allarmante:

/bin/sh : can’t access tty; job control turned off
(initramfs)

Tutto quello che ci rimane e’ una simil-shell che prende il nome di BusyBox o Scatola-Occupata
C’e’ anche una discussione sul sul forum internazionale se volete farvi lo stesso un idea.
C’e’ chi dice sia colpa di /etc/inittab,c’e’ chi dice che e’ colpa del menu.lst..altri ancora incolpano /etc/fstab..
Quello che ho notato personalmente:  la colpa pare essere del file /etc/fstab e del /boot/grub/menu.lst..piu’ precisamente per via dell’UUID (tolto per aggiungere /dev/hda1)
Se potete lasciate l’UUID al posto del device,cioe’..non toccatelo che e’ meglio. Questo meccanismo, introdotto in Feisty col kernel 2.6.20, permette il collegamento univoco con chiave a 128bit della periferica collegata. Un sistema (forse) provvisorio in attesa del passaggio totale a Libata.

Mettiamo, ipotesi, che avete incasinato il menu.lst e fstab..togliendo l’UUID per rimpiazzarlo con /dev/hda1:
Al riavvio ottenete l’errore tty etc..etc
Se usate kde..c’e’ il backup automatico del file, quando modificato, percio’ nel vostro filesystem..in /boot/grub ci deve essere anche il file:

menu.lst~

Ovvero il file come era prima della modifica fatale.

==========
Recupero
==========

Procuratevi un livecd di Ubuntu o una qualsiasi altra distribuzione.
Avviate e aprite un terminale (una volta loggati)

sudo passwd root
Inserite la stessa password per due volte e digitate
su
inserite la password specificata prima e siete root

root@kubuntu:/home/dyve#

L’accounti di root puo’ sempre servire..ore digitate

exit

..per tornare utente normale.

Aprite /etc/fstab per aggiungere la partizione col vostro Linux..esempio: /dev/hda1

sudo nano /etc/fstab

Aggiungete:

/dev/hda1 /media/hda1 ext3 user,noauto,rw 0 0

Create la directory:

sudo mkdir /media/hda1

Montate la partizione:

sudo mount /dev/hda1

Entrate nella partizione

cd /media/hda1/boot/grub

Aprite il browser (konqueror o nautilus)

sudo konqueror /media/hda1/boot/grub

Eliminate il file

sudo rm menu.lst

E rinominate il file

menu.lst~ in menu.lst

Spostatevi in /etc

cd /media/hda1/etc

Fate la stessa cosa coi file:

fstab e fstab.pre-uuid

NOTA: se non avete il backup del file menu.lst dovrebbe funzionare lo stesso..l’importante e’ rinominare il file fstab.pre-uuid in fstab

Riavviate ed estraete il livecd per bootare normalmente.

Related Posts Plugin for WordPress, Blogger...

Il tuo indirizzo ip:
54.226.4.91

Valutazione 3.00 su 5
happy wheels 2 demo

Category:

Senza categoria

Tags:

Commenti via Facebook:

Leave a Reply

Your email address will not be published. Required fields are marked *

*

32 Comments

  • una sola cosa, per diventare root dovrebbe bastare un

    $ sudo su

    anche dal live cd 🙂

      Quota

  • Confermo che l’errore mi si è presentato dopo aver montato i driver per ntfs (3g), e aver modificato l’ fstab per far montare in automatico una partizione ntfs.
    Non ricordo specificatamente se ho sostituito un UUID già esistente, ma sicuramente ho aggiunto un /dev/hdxx…
    Ormai ho formattato e montato la 7.04, ma almeno so perchè è successo…
    Grazie ;P

      Quota

  • misteri..so per certo che uno dei problemi arriva da li..ma ad esempio sul desktop che ho a casa ho levato lo UUID e non e’ successo nulla..

      Quota

  • gforresu ITALY 12 anni ago

    ho sentito che potrebbe anche essere udev…mha. Alcuni consigliano di ripristinare grub. Quando vedo quell’errore francamente ho difficoltà a dare una soluzione 🙁

      Quota

  • si udev e’ senz’altro implicato..infatti io ho ripristinato il menu.lst backuppato prima del patatrac..
    quello che non ho capito..e’ perche’ me lo ha fatto col 2.6.20 appena compilato..e con gli altri 10 kernel no..

      Quota

  • Stefano SWEDEN 12 anni ago

    Ciao,
    io ho questo stesso problema… però io sono alla mia prima installazione, che quindi si blocca e non procede.
    Esattamente mi compare questo code:

    BusyBox v1.1.3 (Debian 1:1.1.3-2ubuntu3) Built-in shell (ash)
    Enter ‘help’ for a list of built-in commands.

    /bin/sh: can’t access tty; job control turned off
    (initramfs)

    Cosa posso fare?
    Grazie
    Stefano

      Quota

  • alistair ITALY 12 anni ago

    ciao, ho lo stesso messaggio di errore all’avvio da quando ho aggiornato ubuntu dalla versione 6.10 alla 7. prima non l’avevo. comunque ho scoperto che basta scrivere exit, dare invio e il sistema si avvia normalmente.
    mi piacerebbe togliermi comunque questo inutile fastidio.

      Quota

  • cosa hai in /etc/fstab?..l’uuid?

      Quota

  • Simone ITALY 11 anni ago

    ciao ragazzi, anche io ho il vostro stesso problema, e il messaggio d’errore è lo stesso che appare a stefano perchè è la prma installazione…ma è la versione 7 che da questo errore o anche le precedenti?

    ciao e grazie
    Simone

      Quota

  • Ciao,
    io ho questo stesso problema… però io sono alla mia prima installazione, che quindi si blocca e non procede.
    Esattamente mi compare questo code:

    BusyBox v1.1.3 (Debian 1:1.1.3-2ubuntu3) Built-in shell (ash)
    Enter ‘help’ for a list of built-in commands.

    /bin/sh: can’t access tty; job control turned off
    (initramfs)

    Cosa posso fare?
    Grazie
    Stefano

    Nel mio caso ho notato che era colpa del lettore, cambiato il lettore funziona 🙂

      Quota

  • @Stez
    quindi hai risolto?
    a volte bisogna passare delle opzioni al boot per vedere se magari e’ un problema di interrupt..come noapic, nolapic, irqpoll etc…

      Quota

  • Bartols SWEDEN 11 anni ago

    ciao a tutti anche io sono alla prima installazione…quando provavo a far partire l’installazione da cd dopo poco tempo si bloccava e dava un errore relativo al lettore ho usato un altro lettore e dava lo stesso errore per ovviare ho usato:”pci ata 133 ide card raid support”…l’installazione partiva sembrava procedere bene ma poi si bloccava sempre durante la copia dei file…poi nn so bene il perchè ieri si è installato ma appena l’ho fatto partire mi ha dato questa schermata:
    BusyBox v1.1.3 (Debian 1:1.1.3-2ubuntu3) Built-in shell (ash)
    Enter ‘help’ for a list of built-in commands.

    /bin/sh: can’t access tty; job control turned off
    (initramfs)

    premetto che nn mi intendo molto di computer spero comunque che potrete aiutarmi

      Quota

  • Bartols SWEDEN 11 anni ago

    ciao a tutti anche io sono alla prima installazione…quando provavo a far partire l’installazione da cd dopo poco tempo si bloccava e dava un errore relativo al lettore ho usato un altro lettore e dava lo stesso errore per ovviare ho usato:”pci ata 133 ide card raid support”…l’installazione partiva sembrava procedere bene ma poi si bloccava sempre durante la copia dei file…poi nn so bene il perchè ieri si è installato ma appena l’ho fatto partire mi ha dato questa schermata:
    BusyBox v1.1.3 (Debian 1:1.1.3-2ubuntu3) Built-in shell (ash)
    Enter ‘help’ for a list of built-in commands.

    /bin/sh: can’t access tty; job control turned off
    (initramfs)

    premetto che nn mi intendo molto di computer spero comunque che potrete aiutarmi

      Quota

  • @Bartols
    in questo caso credo che si debba caricare in qualche modo il modulo piix..al prompt della busy-box prova con

    modprobe piix

      Quota

  • Bartols SWEDEN 11 anni ago

    nn c’è qualche guida che spiega come fare?? io sinceramente nn so nemmeno cosa sia il modprobe piix…cmq ora proverò ad installare open suse 10.2 sperando di avere più fortuna..e che nn mi si ripresentino gli stessi problemi…

    p.s.
    Scusate il doppio post ma il mio pc ogni tanto impazzisce 🙂

      Quota

  • @Bartols
    una guida per un errore generico?..ti auguro di trovarla..hehe

      Quota

  • Bartols SWEDEN 11 anni ago

    e allora nn posso fare altro che sperare che con un’altra distro vada meglio 🙂

      Quota

  • modprobe= programma per caricare i moduli nel kernel
    piix=driver generico per hard-disk sata o sata “emulati” (scsi) gestiti da libata.

      Quota

  • Bartols SWEDEN 11 anni ago

    ho risolto il problema!! :)…alle opzioni di boot prima dell’installazione ho messo “irqpoll” e ha funzionato senza problemi…grazie cmq dell’aiuto

      Quota

  • @Bartols
    e’ indicato qualche post prima..l’opzione irqpoll
    Il problema e’ che l’errore e’ comune..mentre i rimedi sono diversi..
    🙂

      Quota

  • jackass ITALY 11 anni ago

    ciao divilinu come va !!! lol bello il tuo blog mi sono comprato il pc nuovo un quad 6600 su p5neo2 con 4gb di ram e un seagat e da 320 gibbi e nell’installazione di kubuntu mi spunta fuori sto errore(figurati sto usando vista) sebbene le abbia provate tutte non sono riuscito a installare non sai darmi qualche consiglio??

      Quota

  • @jackass
    il supporto ad utenti windows non e’ contemplato su questo blog
    😀
    scherzi a parte, hai letto un po’ di feedback?..

      Quota

  • jackass ITALY 11 anni ago

    certo ho provato tutto e sto pensando che sulle live il kernel (anche sotto consiglio di king) non sia aggiornato a dovere e vorrei provare per questa soluzione …

      Quota

  • non e” che non sia aggiornato, e’ che il livecd ha una configurazione standard che non va bene per tutti i computer..
    Dovresti provare la alternate, oppure se hai un disco sata tentare di caricare i driver piix o disabilitare gli interrupt con noapic, nolapic, irqpoll…

      Quota

  • jackass ITALY 11 anni ago

    ho risolto scaricato la 7.10 e installata 😛

      Quota

  • ciao
    sono alla prima installazione di kubuntu7.04 e mi dà questo problema
    non ho capito cosa fare nelle opzioni di boot…
    schiaccio f6 e mi viene fuori la riga:
    file=/cdrom/preseed/kubuntu.seed boot=casper initrd=/casper/initrd.gz quiet splash —
    se non ho capito male dovrei mettere qui all-generic-ide irqpoll?
    scusate l’ignoranza e grazie

      Quota

  • @luca
    ciao..si vanno inserite di seguito in quella linea che corrisponde all’avvio dell’immagine di /boot/grub/menu.lst

      Quota

  • ok scrivo

    file=/cdrom/preseed/kubuntu.seed boot=casper initrd=/casper/initrd.gz quiet splash – all-generic-ide irqpoll

    faccio invio inizia a caricare ma mi dà errore e si blocca

      Quota

  • alistair ITALY 11 anni ago

    finalmente ho risolto il problema…
    col già citato metodo di sostituire nel file /boot/grub/menu.lst root=UUID=08d00835-0593-4930-9e88-7b3cfb6d7822
    con un semplice root=/dev/hdb1

    hdb1 nel mio caso naturalmente.

    per non fare casini ho: aperto menu.lst da terminale
    sudo mousepad /boot/grub/menu.lst e ho copiato le stringhe
    title Ubuntu, kernel 2.6.20-16-generic
    root (hd1,0)
    kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=08d00835-0593-4930-9e88-7b3cfb6d7822 ro quiet splash
    initrd /boot/initrd.img-2.6.20-16-generic
    quiet
    savedefault
    ho cambiato la parte root=ecceteraeccetera con root=/dev/hdb1
    ho aggiunto il mio nome nella stringa title dopo generic per distinguerlo, ho salvato il file, ho riavviato e ha funzionato…niente più tty e busybox
    questo problema me lo portavo dietro da mesi…con ubuntu, kubuntu e xubuntu aggiornati alla versione 7.
    grazie a chi mi ha dato questo fantastico suggerimento
    alistair

      Quota

  • alistair ITALY 11 anni ago

    errata corrige
    sic, ho cantato vittoria troppo presto, dopo un primo riavvio liscio (senza errori) il giorno dopo il sistema è tornato come prima… coll’ errore job control turned off ecc…
    non posso crederci…
    non ho parole…
    e soprattutto non riesco a spiegarmi il primo riavvio andato a buon fine…
    alistair

      Quota

  • @alistair
    ogni volta che ricevi un aggiornamento del kernel, di qualche modulo, dei linux-headers..in /boot/grub/menu.lst ritorna l’UUID e sparisce la modifica che avevi fatto
    Per questo dovresti modificare l’fstab togliendo l’UUID e mettendo il device come sempre

      Quota

  • I needed to thank you for this wonderful read!

    ! I definitely loved every bit of it. I’ve got you saved as a favorite to check out new stuff you post…

    Here is my site; brooklyn escorts

      Quota